btcq.net
当前位置:首页 >> hBAsE%0.98.6%hADoop2 mAvEn下不下来 >>

hBAsE%0.98.6%hADoop2 mAvEn下不下来

hbase 0.98 安装必须安装hadoop1、zookeeper是hbase必不可少的,它提供了分布式系统当中的高效协调服务. 2、hbase内置了zookeeper,但效果一般不好,一般都选择外置独立的zookeeper. 好长时间不整这个了,其实这些东西自己搭建一遍就能明白个八九了. 试试吧.hbase查询主要靠内存和磁盘,而且是在子节点上进行的.不过多少会有影响,不是因为cpu,而是因为磁盘.hadoop写磁盘的量也很大

编译过程:1.需要安装(必须安装前三个,都非常好安装,直接export就好了)Maven 3.3.1findbugs 3.0.1Java 1.7.0_06Hadoop 2.2.0HBase 0.98.12.生成pom修改hadoop2版本:vi pom.xml2.2.0

hbase启动失败,MasterNotRunningException master没有启动报错,查看hbase启动日志 以及确定hadoop是否正常启动

hadoop1.2+hbase0.95.0+hive0.11.0 会产生hbase+hive的不兼容,创建hive+hbase的关联表就会报pair对异常.hadoop1.2+hbase0.94.9+hive0.10.0 没问题,解决了上个版本的不兼容问题.

1.安装基本toolyum install gcc c++, autoconf, automake, libtool, Java 6, JAVA_HOME set, Maven 3,svn yum Error: Cannot retrieve repository metadata (repomd.xml) for repository: xxxxxsodu vim /etc/yum.repos.d/xxxxx.repo将项[flexbox]中的enabled=

由于 HBase 依赖 Hadoop,它配套发布了一个Hadoop jar 文件在它的 lib 下.在分布式模式下,Hadoop版本必须和HBase下的版本一致.你可以用你运行的分布式Hadoop版本jar文件替换HBase lib目录下的Hadoop jar文件,以避免版本不匹配问题.确认替换了集群中所有HBase下的jar文件.Hadoop版本不匹配问题有不同表现,但看起来都像挂掉了.

问题补充:我自己来回答,是因为hadoop与hbase版本不兼容的问题,后来使用看提示好像是访问hdfs出现了问题.不知道你的hdfs是否工作正常?

hadoop2.x在apache官网直接下载的并没有64位直接能用的版本,如果我们想在64位系统使用,那么就需要重新编译hadoop,否则直接使用32位的hadoop运行在64位的系统上,将会出现一些库不兼容的异常.

问题可能出在这里:1.Hbase与Hadoop版本不匹配;2.集群各节点的系统时间不同步.

重启eclipse,配置hadoop installation directory. 如果安装插件成功,打开Window-->Preferens,你会发现Hadoop Map/Reduce选项,在这个选项里你需要配置Hadoop installation directory.配置完成后退出.

相关文档
网站首页 | 网站地图
All rights reserved Powered by www.btcq.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com