btcq.net
当前位置:首页 >> vs2010 opEnCv2.4.3 >>

vs2010 opEnCv2.4.3

我用的是opencv2.1不知道和2.4.3有什么区别~~如果区别不大!!你了解下这几个函数,(cvCaptureFromcamera();或OpenCamera();二选一,或者两个都了解)和cvQueryFrame()

1、下载软件.2、安装软件.先安装VS2008或VS2010,接着把刚下载的Opencv2.3.1文件解压,建议把解压文件放在C盘,如C:\opencv2.3.1,可以放在任意位置,但在下面的配置中相应把路径改下.3、设置用户变量.计算机>属性>高级系统

1、下载OpenCV2.4.10 SDK:官网链接为:http://sourceforge.net/projects/opencvlibrary/files/opencv-win/2.4.10/opencv-2.4.10.exe/download2、安装OpenCV:直接点击opencv-2.4.10发现,OpenCV的安装不过就是一个解压过程,开始界面如下

看来是没有配置好开发环境.看看系统环境变量的path目录下有没有加上OpenCV-2.4.3\build\x86\vc10\bin;还要在VS的VC++目录里添加好include和lib:包含文件:OpenCV_2.4.3\build\includeOpenCV_2.4.3\build\include\opencvOpenCV_2.4.3\build\include\opencv2库目录:OpenCV-2.4.3\build\x86\vc10\lib都设置好后重启VS再试试.

http://blog.csdn.net/xuhang0910/article/details/45601035推荐你按照这个配置

1、下载软件 下载OpenCV-2.4.0,双击解压到%opencv%(凡是出现%opencv%的地方均替换为你自己opencv的路径全名,如D:\program\opencv). 下载VS2010,安装. 2、配置OpenCV环境变量 计算机->(右键)属性->高级系统设置->高级

你看看opecv网站上代码是用vs那个版本写的.可能版本不一样会有差异.应该跟你opecv的配置没关系.

vc11 -> VS2012 vc12 -> VS2013 vc13 -> VS2014 vc14 -> VS2015 由现在的版本来看,OpenCV 3.2.0只支持VS2015.其实从OpenCV 3.0.0正式版开始就与VS2010不兼容了.如果需要使用最新的版本,还是建议更新VisualStudio的版本.对于VS2010平台,OpenCV 3.0.0 Beta和OpenCV 2.4.10都是兼容的.OpenCV 3.0.0 Beta同样也支持VS2010\VS2012\VS2013 和 VS2015

出错提示你test.cpp无法打开opecv2/opencv.hpp.就是头文件引用错误.如果目录是c:\A\opencv2\opencv.hpp,则在项目头文件目录中增加c:\A目录(你有可能写成了c:\A\opencv2了)

相关文档
网站首页 | 网站地图
All rights reserved Powered by www.btcq.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com